How to get Email Headers

If you're simply looking for a "how to" guide on how to get hold of your email headers you can skip ahead by clicking on one of the links below, but if you would like to know more about email headers carry on reading.

Outlook 2003

  1. To begin, open the email message in a new window by double-clicking on it.
  2. On this new window menu, go to View -> Options. If you do not see options, you may have to reveal it by clicking on the two down arrows at the bottom of the menu.
  3. This will have brought up the Message Options window. The last component of this is the Internet Headers. Right-click inside the headers and choose Select All, then right-click again and choose Copy.
  4. Close the Message Options window.
  5. You should now be looking at the original message window.

Outlook 2007

  1. Double click on the email message so that it is opened in its own window. If you are new to Outlook 2007, you will be working on what is called the Ribbon. This is a series of tabs across the top of the message, Message, Developer etc.
  2. On the Message tab, in the Options section there is a little button with an arrow in it. Click on it and you have the message options menu with the internet headers in the bottom section.
  3. This will have brought up the Message Options window. The last component of this is the Internet Headers.
  4. Right-click inside the headers and choose Select All, then right-click again and choose Copy.
  5. Close the Message Options window.
  6. You should now be looking at the original message window.

Outlook 2010

  1. Double click on the email message so that it is opened in its own window.
  2. On the Message tab, in the Options section there is a little button with an arrow in it. Click on it and you have the message options menu with the internet headers in the bottom section.
  3. This will bring up the Message Options window. The last component of this is the Internet Headers.
  4. Right-click inside the headers and choose Select All, then right-click again and choose Copy.
  5. Close the Message Options window.
  6. You should now be looking at the original message window.

Outlook Express

  1. To begin, open the email message in a new window by double-clicking on it.
  2. From the File menu, click Properties.
  3. Click the Details tab.
  4. Click Message Source. A new window will open containing all the headers and original message:
  5. Right-click anywhere inside this window and choose Select All.
  6. Right-click again and choose Copy.
  7. Close this window, the details window and the message window (so you are back to the main Outlook Express program).
  8. You should now be looking at the original message window.

Mac OS X Mail

  1. To begin, open the email message in a new window by double-clicking on it.
  2. View > Message > Raw Source
  3. Copy the headers by right clicking, selecting all and then choosing copy.
  4. Close the Message Source box.
  5. You should now be looking at the original message window.

Gmail (works for Google Apps as well)

  1. Open the message you’d like to view headers for.
  2. Click the down arrow next to Reply, at the top-right of the message pane.
  3. Select Show original.
  4. The full headers will appear in a new window, simply right-click inside the headers and choose Select All, then right-click again and choose Copy.
  5. Close the Message Source box.
  6. You should now be looking at the original message window..

Yahoo!

  1. Go to Options > General Preferences
  2. Under Mail Viewing Preferences, go to Message Headers, then select ALL.
  3. Hit the small down arrow next to Forward and choose As Inline Text.

Hotmail

  1. In the left pane, click Mail.
  2. In the Folders list, click Inbox.
  3. Once in the Inbox, click on the message that you are getting the headers for.
  4. Right-click the message in the message list, and then click View source.
  5. The full headers will appear in a new window, simply right-click inside the headers and choose Select All, then right-click again and choose Copy.
  6. Close the Message Source box.
  7. You should now be looking at the original message window.

Thunderbird

  1. From Thunderbird menu:
  2. Click "view"
  3. Click "headers"
  4. Select the "ALL" option